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INTRODUCTION 

 

Welcome to the ArcGIS Diagrammer user guide. 

 

ArcGIS Diagrammer is a productivity tool for GIS professionals to create, edit or analyze geodatabase 

schema.  Schema is presented as editable graphics in an environment familiar to users of Microsoft Visual 

Studio 2005.  Essentially ArcGIS Diagrammer is a visual editor for ESRI‟s Xml Workspace Document which are 

created by ArcCatalog, the management application in the ArcGIS Desktop product suite. 

 

The first few chapters of this guide detail the installation and un-installation of ArcGIS Diagrammer.  

However the most useful part of this guide is the chapter entitled getting started.  This chapter contains two 

easy to follow tutorials and is strongly recommended for new users. 

 

Enjoy! 
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HOW TO INSTALL 

 

DOWNLOADING THE SETUP PROGRAMS 

ArcGIS Diagrammer can be downloaded from ESRI‟s ArcScripts website.  Please read all the terms and 

conditions before downloading this or any other code/application from the site. 

 

http://arcscripts.esri.com/details.asp?dbid=14407 
 

If you have received this application from an alternative source or are a current user, please check the 

ArcScripts website regularly for updates. 

 

RUNNING THE SETUP PROGRAM 

Listed below is a step-by-step installation guide for ArcGIS Diagrammer. 

 

Start the Microsoft Windows Explorer application.  Navigate to the folder containing the zip file 

downloaded from the ArcScripts website.  Extract ESRI.ArcGIS.Diagrammer.Setup.2007xxxx.msi from the Zip 

file and double click on ESRI.ArcGIS.Diagrammer.Setup.2007xxxx.msi to start the installer.  When the installer 

will first display a splash screen.  Press Next > 

 

 
 

The next dialog will display a welcome message.  Press Next > 

 

 
 

The next dialog displays a detailed license agreement.  Read through the agreement, if you agree with the 

statement click I Agree and then click Next >. 

 

http://arcscripts.esri.com/details.asp?dbid=14407
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Following the license agreement, a dialog will display a prompt with the installation folder, by default his is:  

C:\Program Files\ArcGIS Diagrammer 

 

If you prefer to install the application on another drive (or folder) then enter a new installation folder or click 

the Browse button to navigate to a folder.  The Disk Cost… button will display the amount of space 

required to install this application.  Click Next > to continue to the next dialog, 

 

 
 

Finally, the installation wizard will display a confirmation message prior to commencing the installation.  

Click Next > to start the installation. 

 

 
 

During the installation process the installation wizard will display a progress bar.  At anytime the installation 

process can be cancelled by clicking the Cancel button however this is strongly not recommended.  If you 

would like to cancel the installation we recommend that you first let the install complete and then follow 

the uninstall procedure detailed in the following section. 
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On successful completion of the install this final dialog will appear.  Click Close to dismiss dialog. 
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HOW TO UNINSTALL 

 

UNINSTALLING ARCGIS DIAGRAMMER 

Diagrammer can be uninstalled using the Add or Remove Programs dialog available from the Windows 

Control Panel.  Launch the Windows Control Panel.  Click Start > Control Panel as illustrated below. 

 
 

Start the Add or Remove Programs dialog.  Click the Add or Remove Programs item. 
 

 
 

When the following dialog appears click Remove a program. 
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From the Add or Remove Program dialog select ArcGIS Diagrammer as illustrated below. 

 

 
 

Click Remove.  A dialog box will appear confirming that you want to remove ArcGIS Diagrammer.  Click 

Yes. 

 

 
 

The uninstall process will take just a few seconds, during which the following progress dialog will be visible. 
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INSTALLATION REQUIREMENTS 

 

OPERATING SYSTEM 

ArcGIS Diagrammer supports the same platform as ArcGIS Desktop 9.2, this includes the following: 

 Microsoft Windows 2000 SP3 (or later) 

 Microsoft Windows 2003 Server SP1 or SP2 

 Microsoft Windows 2003 Server Terminal Services SP1 (with limitations) 
 Microsoft Windows XP Home Edition SP1 or SP2 (with limitations) 

 Microsoft Windows XP Professional Edition SP1 or SP2 (with limitations) 

 Microsoft Windows XP Professional Edition 64-bit (with limitations) 

 Microsoft Windows Vista 32-bit (with limitations) 

 Microsoft Windows Vista 64-bit (with limitations & limitations) 

 

MICROSOFT .NET FRAMEWORK 

ArcGIS Diagrammer requires Microsoft .Net Framework version 2.0.  The .Net framework can be installed 

from here. 

 

ESRI SOFTWARE 

ArcGIS Diagrammer requires ArcGIS Desktop 9.2.   

Please ensure that you have the latest service pack installed.  For a list of the latest services packs please 

click here. 

 

LICENSING 

To read this user guide you must have already installed ArcGIS Diagrammer and accepted the license 

agreement presented in the setup program.  A copy accepted license agreement is located within the 

“license” subfolder of the installation folder.  ArcGIS Diagrammer has a runtime dependency of either 

ArcGIS Engine or ArcGIS Desktop.  The Engine (or Desktop) product must installed and licensed. 

 

ArcGIS Diagrammer uses the following third party components. 

1) ERM Diagram 4.1 

Crainiate Software 

http://www.crainiate.net/products/erm4/default.htm 

2) SandDock 

Divelements 

http://www.divil.co.uk/net/controls/sanddock/ 

3) SandBar 

Divelements 

http://www.divil.co.uk/net/controls/sandbar/ 

 

These components can be used indirectly through ArcGIS Diagrammer without any cost to you as an end 

user.  However you are legally compelled to purchase a developer license(s) if you reference these 

components directly.  This includes modifications to the core ArcGIS Diagrammer assemblies.  Please 

contact Crainiate Software or Divelements for more information on licensing. 

 

STORAGE REQUIREMENT 

The installation size of ArcGIS Diagrammer is approximately 10MB. 

 

SOURCE CODE 

The source code for ArcGIS Diagrammer is located in the “Source” sub-folder in the installation folder. 

http://support.esri.com/index.cfm?fa=knowledgebase.systemRequirements.list&PN=ArcInfo+Desktop&pName=ArcInfo+Desktop&PVName=&PID=43&count=1&pvid=352&VID=997#Limitations
http://support.esri.com/index.cfm?fa=knowledgebase.systemRequirements.list&PN=ArcInfo+Desktop&pName=ArcInfo+Desktop&PVName=&PID=43&count=1&pvid=352&VID=944#Limitations
http://support.esri.com/index.cfm?fa=knowledgebase.systemRequirements.list&PN=ArcInfo+Desktop&pName=ArcInfo+Desktop&PVName=&PID=43&count=1&pvid=352&VID=945#Limitations
http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=29391
http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=34020
http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=34020
http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=29391
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en
http://support.esri.com/index.cfm?fa=downloads.patchesServicePacks.listPatches&PID=43
http://www.crainiate.net/products/erm4/default.htm
http://www.divil.co.uk/net/controls/sanddock/
http://www.divil.co.uk/net/controls/sandbar/
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POST INSTALLATION REQUIREMENTS 

 

ESRI .NET ASSEMBLIES 

ArcGIS Diagrammer requires the ESRI .Net assemblies to be installed in the Global Assembly Cache (or 

GAC).  If you installed the Microsoft .Net Framework 2.0 prior to installing ArcGIS 9.2 then the ESRI assemblies 

will have been automatically installed in the GAC. 
 

If the .Net Framework was installed after ArcGIS then you must following the steps below to install the ESRI 

assemblies into the GAC.  You may also use the following the steps to verify the installation of the ESRI 

assemblies. 

 

Display the Add or Remove Programs dialog from the Windows Control Panel (see How to Uninstall above 

for details),  select ArcGIS Desktop from the list of installed programs 

 

 
 

Click the Change button to launch the installer.  At this point you may be asked for the source media or 

access to a network folder that was used to install ArcGIS Desktop. 

 

 
 

Select Modify and then click Next >.  The following dialog will appear listing all the currently installed 

components of ArcGIS 9. 
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Click on .NET Support and select Will be installed on local hard drive. 

 

 
 

Click Next > 

 

 
 

At the confirmation prompt click Next > again.  As the new files are installed the following progress dialog 

will appear.  If necessary, the installation can be cancelled by clicking the Cancel button, but this is 

strongly not recommended. 
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When the installation is complete the following dialog is displayed. 

 

 
 
Finally, click Finish to dismiss the dialog. 
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GETTING STARTED 

 

INTRODUCTION 

This chapter will step through two exercises.  The first exercise will use ArcGIS Diagrammer (AD) to design a 

simple geodatabase.  The second exercise will start by analyzing an existing the schema of an existing 

geodatabase, make a few modifications and then load the edited schema to a new geodatabase. 

 
Ultimately the goal of these exercises is to demonstrate AD‟s usefulness and ease of use. 

 

EXERCISE ONE: DESIGNING A GEODATABASE 

Prior to AD there were two ways of authoring geodatabase schema, designers could use ArcCatalog or 

third party CASE tools like IBM‟s Rational Rose or Microsoft‟s Visio. 

 

ArcCatalog is a very focused application for schema creation.  But is, of course, non-graphical making a 

design collaboration and validation difficult.  For complex designs, schema creation with ArcCatalog 

would be very time consuming. 

 

CASE tools allow designers to create industry standard UML diagrams but had performance issues with 

complex designs.  Additionally, some geodatabase objects like topology datasets and annotation feature 

classes were not supported. 

 

In this exercise you will discover a third method of schema creation. 
 

Let‟s commence this exercise by starting AD from the windows start menu.  On computer with Windows XP 

click Start > All Programs > ArcGIS > ArcGIS Diagrammer > ArcGIS Diagrammer as shown below. 

 

 
 

AD will start without any diagrams loaded.  To create a new empty diagram click File > New. 
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A new tab will be added to the AD application with the name Untitled, this is the default name for new 

diagrams. 

 

 
 

In the Palette window scroll down until you see the Feature Dataset item.  As you place you cursor over this 

and other items a brief description will appears in a balloon tooltip. 

 

 
 

Drag the Feature Dataset item from the palette and drop it into the diagram. 
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The drag and drop operation added a new feature dataset called Empty to the diagram.  By default, 

datasets added from the palette will have a WGS84 spatial reference. 

 

 
 

To change the name of the feature dataset select it by clicking it with the left mouse button. 

 
 

In the Properties window highlight the text Empty next to the (Name) properties in the Dataset category. 

 

 
 

Type World and then press Enter to update the feature dataset. 



ESRI ArcGIS Diagrammer User Guide 

 Page 17 of 85  December 10, 2007 

 
Scroll up the list of geodatabase objects in the Palette window and locate the Polygon item under the 

FeatureClasses category. 

 

 
 

Drag and drop the Polygon item into the diagram. 

 

 
 

Similarly add a Raster Dataset and Rater Band to the diagram as shown below. 
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Next we need to indicate some geodatabase structure.  Namely, the feature class needs to associated 

with the feature dataset and the raster band to the raster dataset.  To associate objects AD must to 

switched to Link Mode. 

 

Click Tools > Link Mode. 

 

 
 

To link the feature class to the feature dataset start by dragging a link from the center of the feature 

dataset to the center of the feature class. 
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Likewise, link the raster band to the raster dataset by dragging a link from the center of the raster dataset 

to the center of the raster band. 

 

 
 

Before continuing let‟s restoring the normal interaction mode by clicking Tools > Normal Mode. 
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Returning to the Palette, drag and drop a coded value domain to the diagram. 

 

 
 

In a previous step you renamed the feature dataset from Empty to World.  This time rename the newly 

added domain to Language.  Start by selecting the domain by click it with the left mouse button.  In the 

property window change the (Name) from Empty to Language. 
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We are going to use this coded value domain to host a list of language names and codes.  New coded 

value domains added from the palette window have a sample coded value.  Let‟s start by modify the 

sample coded value and then move on to added additional coded values for other languages. 

 

Select the first coded value item in Language domain. 

 

 
 

In the properties window set code to EN and name to English. 
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To add other coded value items right click on the domain and select Add Coded Value Item.  Repeat this 

so that there are two new blank coded value itmes. 

 

 
 

Select the second coded value item in the Language domain. 
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Set the code and name for the second coded value item to DE and German respectively.  Likewise, assign 

ES/Spanish to the third and last coded value item. 

 

 
 

The easiest way to browse the objects in your diagram is to use the Catalog Window.  If the catalog 

window is not visible then click View > Catalog.  For performance considerations the catalog is not 

automatically updated when objects are removed, added, linked or unlinked.  In the catalog window click 

the Refresh button as shown below. 

 

 
 

The catalog window has three view types.  The first and default view is similar to the tree structure displayed 

in ArcCatalog.  However unlike ArcCatalog, this view lists domains and other geodatabase object that are 

not normal shown like subtypes. 
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Click the Categorized view button.  This button groups all geodatabase objects based on type.  This view 

allow you to quick answer questions like “Does the geodatabase have a topology dataset?” or “How 

many geometric networks are there?”. 

 

 
 

Lastly click the Alphabetical view button.  This view arranges all geodatabase objects in an alphabetical 

order irrespective of the geodatabase hierarchy.  This view allows you to efficiently locate objects that may 

be difficult to locate in the catalog view, for example, “Where is the subtype called „residential‟?”. 

 

 
 

Hint:  If the alphabetical view contains hundreds or thousands of objects scrolling may be cumbersome.  To 

quickly locate an object by name, type some or all of the object‟s name into the window.  This will 

automatically scroll the view to the named object. 

 

Right clicking on any geodatabase object in any view will display a context menu with the items Scroll and 

Flash.  Selecting scroll will cause the diagram to pan to the location of the selected object.  Scroll will not 

affect the diagram zoom scale.  Flash will cause the object in the diagram to flash yellow three times.  To 

illustrate this, right click on the raster band called Band_1 and select Flash. 
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Below is a screenshot demonstrating the flashing effect that you will see after selecting Flash. 

 

 
 

So far you have added a domain, feature dataset, feature class, raster dataset, raster band and made 

some associations.  Before continuing let‟s validate the diagram.  Validate is the process of scanning the 

diagram for errors and inconsistencies. 

 

Click Tools > Validate. 

 

 
 

If the Error List window is currently not display then click View > Error List.  Please ensure that the Errors and 

Warnings buttons on the toolbar are depressed.  Depressed buttons will be colored orange as pictured 

below. 
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You should see three errors and one warning displayed in the error list window.  Over the next few pages 

we are going to locate and fix these errors. 

 

 
 

Of the three errors, two have the description “Dataset name „Empty‟ is duplicated”.  Obviously there is a 

name conflict, let‟s start by locating the offending objects.  Select the two errors.  To select more than one 

error use the CONTROL key.  Right click over one of the selected errors and click Flash. 

 

 
 

In the diagram you will see both the feature class and the raster dataset flash yellow.  One of these objects 

must be renamed to avoid the naming conflict. 
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Select the feature class called Empty and change its (Name) to Countries. 

 

 
 

Similarly, change the (Name) of the raster dataset from Empty to Temperature. 
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Refresh the list of errors by clicking Tools > Validate.  Now, you only have one error and one warning.  The 

error description is “Field [SHAPE_Length] is too long”.  To find out what table or feature class the field 

belongs to, right click on the error and click Select. 

 

 
 

The Countries feature class is selected in the diagram. 

 

To check table and field names the validate command uses a database specific validator.  In this exercise 

you will be ultimately applying the schema generated from this diagram to file geodatabase.  So, let‟s 

select a file geodatabase validator and re-validate the diagram. 

 

Click the validator dropdown button on the error list window toolbar, select file geodatabase. 
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Revalidate the diagram by clicking Tools > Validate. 

 

 
 

Now, we only have a single warning.  All table and field names are valid for file geodatabases. 

 

The warning description explains that the domain Language is not used.  This is classified as a warning 

because it will not cause an error in the target geodatabase.  For this reason, warnings can be ignored. 

 

In this case, let‟s create new field in the feature class Countries and assign the domain Languages to it.  To 

create a new field on Countries, right click on the feature class and select Add Field. 
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Select the newly added field. 

 

 
 

In the property window update the following properties. 

 

Property Value 

(Name) SpokenLanguage 

AliasName Spoken Language 

DefaultValue EN 

Domain Language 

FieldType esriFieldTypeString 

Length 2 

 

Notice that both the Domain and FieldType properties have dropdown menus.  This helps eliminate 

typographical errors. 
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Once again, click Tools > Validate to verify that you have eliminated all errors and warnings. 

 

 
 

With the three errors and warnings removed we can move on to creating an xml workspace document 

from this diagram. 

 

Click File > Save Untitled As… 
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When the save as dialog appears, navigator to the C:\Temp folder and enter World Data Model as the 

output file name.  Click Save. 

 

 
 

Xml workspace documents can be loaded into new or existing geodatabase using ArcCatalog.  In this 

exercise we will load the document into a new file geodatabase. 

 

Click Start > All Programs > ArcGIS >ArcCatalog to start ArcCatalog. 
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In ArcCatalog, navigate to the C:\Temp folder as shown below.  You will see the Xml file created in the 

previous step. 

 

 
 

Create a new file geodatabase by clicking File > New > File Geodatabase. 

 



ESRI ArcGIS Diagrammer User Guide 

 Page 34 of 85  December 10, 2007 

 
 

Select the new file geodatabase in the ArcCatalog table of contents.  Right click and select Import > XML 

Workspace Document. 

 

 
 

Xml Workspace Documents can contain schema, data or both.  When the Import Xml Workspace 

Document window appears click Schema Only to indicate that no data will be imported. 

 

Enter the full file name of the Xml Workspace Document created by AD, for example, C:\Temp\World Data 

Model.xml. 

 

Click Next >. 
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The next dialog will summarize the datasets and domains in the xml workspace document.  Click Finish to 

start the schema loading process. 

 

 
 

As the dataset and domains are loaded the following progress dialog will appear. 
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When the progress dialog disappears click View > Refresh in ArcCatalog to refresh the contents of the file 

geodatabase. 

 

 
 

In the ArcCatalog, examine the geodatabase structure.  Confirm that the Countries feature class was 

created in the World feature dataset. 
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Right click on the Countries feature class and select Properties.  Click the Fields tab and SpokenLanguage 

field list.  Verify that the alias, default value, domain and length are correct and identical to the properties 

assigned in AD. 

 

 
 

Click Cancel to dismiss the Feature Class Properties window. 

 

Returning to the AD application, click File > Close. 
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When prompted to close the current diagram without saving click No. 

 

 
 
Congratulations.  You have just designed a geodatabase using ArcGIS Diagrammer. 
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EXERCISE TWO: MODIFYING THE SCHEMA OF AN EXISTING GEODATABASE 

 

In the previous exercise you started with a blank diagram and authored new geodatabase schema by 

adding items from the palette.  In this exercise you will take the schema from an existing geodatabase, 

modify it in AD and then apply it to a new geodatabase. 

 

This exercise assumes you have ArcTutor installed.  The screenshots and instructions below are based on an 

ArcTutor installation folder of C:\Program Files\ArcGIS\ArcTutor, but this may be different on your 

computer. 

 

In ArcCatalog navigate to the EditingWithArcGIS sub-folder in the ArcTutor installation folder. 

 

 
 

Right click on the Montgomery_full.gdb geodatabase and select Export > XML Workspace Document. 
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When the Export XML Workspace Document window appears check Schema Only so that no data is 

exported.  In the output XML file box, enter C:\Temp\Montgomery.xml.  By default, metadata (if any) will 

be included in the xml workspace document. 

 

Click Next to proceed to the next step. 

 

 
 

The next dialog will summarize the geodatabase objects that will be exported to the XML file.  By default, all 

geodatabase objects are selected for export.  Click Finish to commence the export. 
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During the export operation the following progress dialog will appear. 

 

 
 

When the export operation has completed the progress dialog will disappear.  Returning to AD, select File > 

Open from the main menu. 
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An open file dialog will appear.  Navigate to the C:\Temp folder and select the export XML workspace 

document Montgomery.xml.  Click OK to load XML workspace document. 

 

 
 

When AD has finished loading the XML workspace document a new tab will added to application.  The 

intial title on the tab is taken from the filename of the source XML workspace document. 

 

AD features a docking environment very similar to Microsoft Visual Studio 2005.  Take some time to famialize 

yourself.  First click the pushpin icon on the Palette window, this collapses the window to the side of the 

application.  Next, click and drag the Error List window, as you commerce dragging you will see docking 

prompts appear around the application as shown below. 

 

The docking prompts are drop targets for dragged windows.  In the center of the application there are five 

docking prompts, drop the Error List window on the bottom prompt. 
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The Error List window will not be used in this exercise, for now, collapse the window to the bottom of the 

application by clicking the pushpin icon in the title bar. 

 

 
 

Diagrams are often much larger than your screen.  AD provides three ways to navigate diagrams, the first 

and most obvious is to use the scroll bars on the right and bottom of the diagram.  The second way, shown 

below, is to click in the Overview window.  If the Overview window is not displayed then click View > 

Overview.  Clicking in the Overview window will center the diagram around the location without changing 

the diagram scale. 
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When the diagrams are large, objects in the Overview widnow may be difficult to recognize.  The third and 

last way to navigate diagrams is to use the Catalog window.  If the Catalog window is not displayed then 

click View > Catalog.  This is easily the most efficient way to navigate your diagram.  Let‟s locate Parcel’s 

Non-Residential subtype.  In the Catalog window, expand the Landbase feature dataset and Parcels 

feature class.  Right click on Non-Residential and select Scroll. 

 

 
 

The diagram will center around the Non-Residential subtype belonging to the Parcels feature class.  Notice 

that it is selected in the diagram and its properties are displayed in the Properties window. 
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Next, let‟s locate the domain called FittingType.  In the Catalog window, right click on FittingType and 

select Scroll. 

 

 
 

Until now we have been interacting with the main diagram.  However AD allow the creation of additional 

sub-diagrams for analyzing or modifying complex objects.  Domains, relationships, geometric networks and 

topology datasets all have sub-diagrams. 

 

Right click on the FittingType domain and select Open Domain Diagram. 
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A new tab will be added to AD with the name of the selected domain in the title.  A domain diagram is not 

editable, its primary use is to show what tables and/or feature classes are using the domain, if any. 

 

By default, the diagram scale is 100% or actual size.  Because the domain diagram is quite large let‟s 

change the diagram scale to 50% so that more is visible.  In the lower right hand corner of the application, 

click the left mouse button on the scale dropdown menu and select 50%. 

 

 
 

Domain diagrams only displays objects fields and subtypes fields that directly reference the selected 

domain.  By default, AD uses a hierarchical layouts for new diagrams.  Click the Circular button on the 

Layout toolbar. 
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The shapes in the domain diagram will be displayed in a circular pattern as shown below.  Feel free to 

experiment with the other layouts like Forced Direct and Orthogonal. 

 

 
 

Close the domain diagram for FittingType by click the close button on the tab. 

 

 
 

We have now returned to the main diagram.  Next we want to make some changes to the Water_Net 

geometric network.  It may take some time to locate the geometric network in the diagram so let‟s use the 

catalog window.   Click the Categorized button in the Catalog window. 
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The categorized view is great for finding geodatabase objects if you are unsure of the exact name or its 

location.  Expand the Geometric Network node, we can see that this xml workspace document only has 

one geometric network called Water_Net.  Right click on the geometric network and select Scroll.  This will 

move the horizontal and vertical scrollbars so that the geometric network is located in the center of the 

application. 

 

 
 

Right click on the geometric network and select Open Geometric Network Diagram. 

 

 
 

A new geometric network diagram will be added to AD.  The geometric network is located near the top of 

the diagram and its parent feature dataset at the bottom.  All feature classes that belong to the feature 

dataset are located in the middle of the diagram.  Participating feature classes will have a blue link 
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connecting them to the geometric network.  In the screenshot below we can see that LaterialDiam does 

not participate in the geometric network. 

 

 
 

With the left mouse button drag a box over the blue links to select them. 

 

 
 

After selecting the links change the ShowLabels property in the property window to True. 
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The link labels will display the network ancillary role which can be either Normal or Source/Sink.  Click the 

Montgomery tab to return to the main diagram.  Right click on the Water_Net geometric netwok and 

select Open Edge Edge Connectivity Diagram. 

 

 
 

The edge edge connectivity diagram allows the visualization and modification of edge edge connectivity 

rules.  The from and to edge feature classes are positioned at the top and bottom of the diagram 

respectively.  Each blue link represents an edge edge connectivity rule.  Locate the rule that connects the 

Distmains feature class to the Hydrant Laterals subtype.  Select the link (or rule) with your mouse, in the 

properties window change the ShowLabels property to True. 

 



ESRI ArcGIS Diagrammer User Guide 

 Page 51 of 85  December 10, 2007 

 
 

The rule label shows a list of valid junctions for this edge edge connectivity rule.  There must always be at 

least one junction for a rule and one of which must be the default. 

 

Now lets add a new edge edge connectivity rule.  Click Tools > Link mode from the main menu.   

 

 
 

In the diagram, click the Distmains with the left mouse button and drag to Service Laterals subtype. 
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When you release the left mouse button over Service Lateral a new connectivity rule will be added.  Before 

continuing restore the interactive mode back to normal by clicking Tools > Normal Mode from the main 

menu. 

 

 
 

Select the new connectivity in the diagram.  Change the ShowLabels properties to True. 
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At present the new rule does not have any junctions defined.  Click the ellipse button next to the 

JunctionSubtypes property as shown below. 

 

 
 

The ellipse button will launch a generic collection editor dialog. 

 

 
 

Click the Add button to add a new junction to the collection.  For the Dataset Id property, click the 

dropdown menu and select Fittings. 

 



ESRI ArcGIS Diagrammer User Guide 

 Page 54 of 85  December 10, 2007 

 
 

Set the Subtype Code to Tap. 

 

 
 

Click OK to update the junction collection. 
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There are two more properties that need to be updated.  Set the DefaultJunctionId to Fittings and the 

DefaultJunctionSubtype to Tap. 

 

 
 

To print the contents of the currently selected tab click File > Print.  By default, AD uses the default printer 

and page size.  To change either of these click File > Print Setup. 

 

 
 

In the screenshot below, shows the printer setup dialog for changing printer properties. 
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However, in some cases you may want to export a diagram to an image for inclusion in a report or email 

message.  To export a diagram click File > Export. 

 

 
 

The default output image type is JPEG.  To choose an alternative image type click the Save as type 

dropdown menu. 
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Sometimes it may be necessary to view two or more diagrams simultaneously.  To commence a docking 

operation start dragging the tab towards the center of the application. 

 

 
 

To dock the tab in the lower half of the application drop the tab on the lower docking hint as shown 

below. 
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ARCGIS DIAGRAMMER OPTIONS 
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EXCEPTIONS 
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FAQ 

 

WHAT ARE THE LIMITATION? 

 

WHAT IS NOT SUPPORTED BY ARCGIS DIAGRAMMER? 

 

WHY CAN’T I EXPORT OR IMPORT XML WORKSPACE DOCUMENTS IN 

ARCCATALOG? 

You need either a ArcEditor or ArcInfo license. 

 

REFERENCES 

 

Geodatabase XML 

http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?id=2016&pid=2009&topicname=Geodatabase_XML 

ESRI 

November 9, 2006 

 

 

XML Schema of the Geodatabase 

http://downloads.esri.com/support/whitepapers/ao_/XML_Schema.pdf 

ESRI 

February, 2004 

 

FEEDBACK 

 

ENHANCEMENTS OR BUGS? 

Please send your comments and/or bugs to us using the following link. 

http://groups.google.com/group/arcgis-diagrammer 

 

  

http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?id=2016&pid=2009&topicname=Geodatabase_XML
http://downloads.esri.com/support/whitepapers/ao_/XML_Schema.pdf
http://groups.google.com/group/arcgis-diagrammer
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LEGAL STUFF 

 

THE LICENSE AGREEMENT 

Reservation of Ownership and Grant of Rights 

This is a license agreement (Agreement) and not an agreement for sale. ESRI and its licensor(s) (hereinafter 

collectively referred to as "Author") retains exclusive rights, title, and ownership of the copy of the Geochat 

sample code (hereinafter referred to as "Sample Code") licensed under this Agreement and grants you 

(hereinafter referred to as "Developer") a personal, nonexclusive, nontransferable, worldwide, royalty-free 

license to use, copy, edit, modify, merge, incorporate, and/or prepare derivative work(s) of the Sample 

Code with any new scripting code and/or data, and thereafter the copyright license to demonstrate, 

reproduce, redistribute, and publicly display the derivative work(s) embedding the Sample Code to 

Developer's clients for the client's own internal use. All rights not specifically granted in this Agreement are 

reserved to the Author. In the event Developer transfers a copy of the unmodified Sample Code to another 

party, Developer expressly agrees to always include this Agreement file with all copies of the unmodified 

Sample Code.  

Copyright 

The Sample Code is owned by the Author and is protected by United States copyright laws and applicable 

international laws, treaties, and/or conventions. The following Author attribution information must be given 

in comment form in the Sample Code, in a "Help-About" dialog box, in a supporting digital "Read Me" file, 

and/or provided in digital form for on-line documentation, and at the beginning or end acknowledgment 

page of any hard-copy documentation:  

“Copyright © 2007 ESRI. All rights reserved. 

Portions of this work are: 

Copyright © 2007 Divelements. All rights reserved. 

Copyright © 2007 Crainiate Software. All rights reserved.” 

The parties mutually agree that Developer may make an application for copyright registration in the 

derivative work(s) prepared by Developer based on the preexisting Sample Code so long as Developer 

identifies and discloses all respective ownership rights in preexisting material(s) that comprise Developer's 

derivative work(s) in section 6, Derivative or Compilation on Form TX and/or any other applicable form(s) of 

the United States Copyright Office or the applicable forms in other legal jurisdictions. 

Disclaimer of Warranty 

Developer expressly acknowledges that the Sample Code is unsupported code and that no technical 

support shall be provided to Developer by the Author. 

THE SAMPLE CODE ARE PROVIDED "AS-IS," WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, BY 

STATUTE OR OTHERWISE, INCLUDING, BUT NOT LIMITED TO ALL IMPLIED WARRANTIES OF MERCHANTABILITY, 

FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE AUTHOR DOES NOT WARRANT THAT THE 

OPERATION OF THE SAMPLE CODE SHALL BE UNINTERRUPTED OR ERROR FREE. DEVELOPER BEARS ALL RISK AS 

TO THE QUALITY AND PERFORMANCE OF THE SAMPLE CODE. 

Exclusive Remedy and Limitation of Liability 

The parties expressly agree that the Author's liability hereunder for any damages to Developer, regardless 

of the form of action, shall not exceed the total amount paid for the license granted herein. 
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IN NO EVENT SHALL THE AUTHOR BE LIABLE TO DEVELOPER FOR COSTS OF PROCUREMENT OF SUBSTITUTE 

GOODS OR SERVICES, LOST PROFITS, LOST SALES OR BUSINESS EXPENDITURES, INVESTMENTS, OR 

COMMITMENTS IN CONNECTION WITH ANY BUSINESS, LOSS OF ANY GOODWILL, OR FOR ANY INDIRECT, 

SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THIS AGREEMENT OR USE OF THE 

SAMPLE CODE, HOWEVER CAUSED, ON ANY THEORY OF LIABILITY, AND WHETHER OR NOT THE AUTHOR HAS 

BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. THESE LIMITATIONS SHALL APPLY NOTWITHSTANDING 

ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. 

Governing Law 

This Agreement is governed by the laws of the United States of America and the state laws of California 

without reference to conflict of laws principles.  

Entire Agreement 

The parties agree that this Agreement constitutes the sole and entire agreement of the parties as to the 

matter set forth herein and supersedes any previous agreements, understandings, and arrangements 

between the parties relating hereto when Developer assents to be bound by these terms and conditions by 

clicking the "I Accept" button below. 

 


